unavailability of statistics and registrar list on public website
Incident Report for DNS Belgium
Resolved
Incident has been resolved, functionality validated
Posted Jun 25, 2024 - 17:58 UTC
Monitoring
Remediation has been implemented, we're monitoring if all functionality is restored
Posted Jun 25, 2024 - 17:57 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2024 - 17:47 UTC
Identified
We are currently facing an issue with the statistics and registrar list portions of our public website dnsbelgium.be, we're working on remediation
Posted Jun 25, 2024 - 17:47 UTC
This incident affected: DNS Belgium website.